Connection failed, please try again. (Windows defender issues?)

And windows defender has found a new and exciting way to break things?

Intiface/GHR was working for about 1 month after the last issue with Defender. But now I get ‘connection failed, please try again’ with GHR (Intiface central is running and connected). Reinstalling it and Intiface central (with all windows defenders functions disabled) does not resolve. GHR also does not seem to be able to write to its log (repeatedly trying to connect generates no log entries).

GHR and Intiface central have been manually whitelisted in every way I know how (including overriding the ‘Exploit Protections’ for easyhook exes for GHR). But I am not convinced Defender is paying any attention to the control panel settings (and it renables some every restart). Toys/controllers work normally using other apps.

As of 3/20/24 and whatever crapware updates MS has pushed out, is anyone able to get this to work with Windows 10 home?

Or, what OS is GHR confirmed working under? (Linux? Do I buy a pro version of Windows 10 to not have to fight windows defender every couple of weeks?)

Many thanks,


Update: running both Intiface Central and GHR as administrator does not resolve the issue, but I do get an actual log entry now:

From GHR (Does this indicate that windows is preventing easyhook from functioning?)

2024-03-21 09:49:21.1966|INFO|IntifaceGameHapticsRouter.MainWindow|Application started.

2024-03-21 09:49:21.4388|ERROR|IntifaceGameHapticsRouter.ModControl|System.ApplicationException: STATUS_INTERNAL_ERROR: Unable to query process token. (Code: 5)
at EasyHook.NativeAPI.Force(Int32 InErrorCode)
at EasyHook.RemoteHooking.GetProcessIdentity(Int32 InTargetPID)
at IntifaceGameHapticsRouter.ModControl.<>c__DisplayClass26_0.b__3(Process currentProc)

There’s a ton of issues with the GHR that I need to address. I think our process lookup (which was taken from an old unity injector) now has the same signature as some sort of malware. Turns out injecting code into running processes looks shady. :expressionless:

Trying to figure out what the best way is to fix things right now.

BTW, check this post for info on a possible fix: Refresh Process List Crash - #3 by qdot

Ok - here’s what finally worked: (after determining that it is basically impossible to remove/turn off defender on Win 10 home in a meaningful way, and that it now largely ignores any attempts to whitelist GHR)

Install a better security suite. Apparently, the one thing those window-lickers in Redmond got right was setting defender up so that it will stop itself as long as another security suite is running.

I used avast (free) and whitelisted everything in the folders with GHR and Intiface Central, but probably there are other options.

This appears to work (and survived a restart), though I have been running both exes as administrator just to be sure.