How to change server address in ButtplugKnight?

I’m trying to connect my toy to the Intiface app on my phone to then redirect it to ButtplugKnight for Hollow Knight. For all other games I’ve tried this with there has been some config setting whether in the mod manager for the game or within the game files that allows me to change the default server url in order to connect it with my phone. But for this one I cannot find it anywhere. I can’t see any config settings on Scarab, and no files I can edit for the mod itself. Can anyone help me please?

We just released a new utility for situations like this, the “Repeater Mode” in Intiface Central 2.5.6. Here’s a quick tutorial on how to use it.

  • Start Intiface Central on your phone
  • Go to the App modes panel, make sure it’s set to “Engine” mode, and that “Listen on All Interfaces” is turned on.
  • Start server on phone
  • On desktop, start Intiface Central v2.5.6
  • Go to Settings in Intiface Central, turn on “Show Repeater Mode”
  • Go to the App Modes tab, change the App Mode to “Repeater”
  • Look at the server address on your phone, and copy that to the Repeater Server Address
    • IMPORTANT NOTE: MAKE SURE YOU USE THE FULL ADDRESS, i.e. ws:// or whatever it is. If you just put in the IP without the ws:// part, it will crash (If you see a RelativeUrlWithoutBase error in the logs, this is why). This is a bug that will be fixed in the next version of Intiface Central.
  • Hit start on Intiface Central on the desktop
  • Start Hollow Knight, make sure ButtplugKnight shows up as connected on phone.

Just reply here if you have any issues.