[solved] Can't connect to Hismith Premium anymore

Hello, 10 minutes ago I was connected to my hismith in intiface central, everything was fine. I decided to change the name of the device from “HISMITH” because I didn’t want that showing up in Bluetooth. After changing the name, I couldn’t connect anymore, so I tried to change it back to “HISMITH” using their app, but I still can’t connect again. Now it says this:

Any idea why or how I can fix?

Edit: I see the device name should be “HISMITH” but for some reason it’s “\u{7}HISMITH”. I have no idea why this is the case, I’m guessing that’s causing it not to be recognized? I tried adding the name “\u{7}HISMITH” to the intiface config, but it seems to break the entire program (because of the forward slash)

Edit 2: Okay I figured it out. The problem seemed to be that I was using an iPhone to rename the hismith. For some reason using an iPhone adds “\u{7}” to any name you’re trying to set. I tried using an android and it was able to rename my device just fine.

Yeah we use device names to identify devices. Interesting that there’s that bug in the hismith app that adds that character though!

Soon we’ll have a way to add more search names for certain devices, in cases like this where you’d like to change the name.