Using OSR2/SR6 with current Intiface Central Version (~2.3.0)

ADMINISTRATOR NOTE: THIS HAS CHANGED IN INTIFACE CENTRAL v2.6, PLEASE SEE BOTTOM OF COMMENT THREAD

Currently it is not possible to set up Tempest OSR2 or SR6 in the Intiface Central GUI.

Its still possible to use if you change the buttplug-device-config.json.

  • To do that you need to find the used COM Port in the Device Manager. (In my case COM13)
  • Then open the device config file: “%appdata%\com.nonpolynomial\intiface_central\config\buttplug-device-config.json”
  • Search for “tcode-v03”. It should look like this:
"tcode-v03": {
      "serial": [
        {
          "port": "default",
          "baud-rate": 115200,
          "data-bits": 8,
          "parity": "N",
          "stop-bits": 1
        }
      ],
      "defaults": {
        "name": "TCode v0.3 (Single Linear Axis)",
        "messages": {
          "LinearCmd": [
            {
              "StepRange": [
                0,
                100
              ],
              "ActuatorType": "Position"
            }
          ],
          "FleshlightLaunchFW12Cmd": {}
        }
      }
    },
  • Find the line " “port”: “default”, " and swap default with the COM Port you looked up earlier.
    It should look like this: " “port”: “COM13”, ". COM needs to be in capital.

If you now open Intiface Central the device should show up after you clicked “start scanning”

1 Like

Is this still an applicable guide?

I took the steps mentioned above and no joy.

I see this in the Log of intiface.

It does see COM3 but…

Actually I got it.

Turns out there was one more thing I needed to change and that was matching up the baud-rate that was displayed in the JSON to the baud-rate in device manager. I had been going off of what was in the IDE.

Thanks.

For me at least, changing the baud rate in the JSON to match device manager didn’t work. It would connect to the toy, but not move it. Changing the baud rate in device manager to 115200 like the JSON made it work. Unfortunately, the range limit sliders only work for the oscillation toggle. Anything else controlling the OSR through initface will use the toys full range of motion, which makes it functionally unusable.

Is this still the only way to use OSR2/SR6?
As it still works at least in a quick test I’ve done (on version 2.5.6) but before going ahead with actually using it I wanted to check if something has changed since. Because scanning serial ports does show that the program’s latest version does find it but it ends up being disregarded or something for it to not show in the scanned device list.

Yup. We’re still working toward a better interface for adding user-created hardware.

1 Like

Nice, thank you. :bowing_man:

What would be the best way to keep an eye on where it is in terms of development roadmap/in progress so to know how it’s going or if it’s being put into the backlog for something else more urgent? (presuming I haven’t missed it somewhere like in github issue/ticket system) As it’s been sometime since the post on eroscripts saying that it would be coming soon.

Additionally would it be okay with yourself if I posted on there saying about this being currently the only way and include information above on how to check in on it’s status or rather I just point people to this post/forum whom are wanting to keep an eye on this aspect of the program? (and so that you don’t get bombard possibly about how it’s going in the future)

It looks like when I upgraded intiface this morning I lost connection with my OSR2/FunSR1. Was working fine.

The config system changed drastically with v3, these instructions are no longer valid.

You can now add serial port information in the Device Tab UI, as long as you have the Serial Port device manager turned on.

Is there a tutorial for setting up OSR2/SR6 for new version? Just got mine and trying to find it with scanning but not sure on protocol type/portname/baud

Those configurations rely on information we do not have about your hardware. Check with your hardware manufacturer or community.